[PATCH] D115416: [lld-macho] Prevent writing map files on the critical path
Vincent Lee via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Dec 9 11:25:28 PST 2021
thevinster added a comment.
I'll admit your suggestion is clever, but I think it sacrifices on readability. How would something like this be modeled in the `parallelForEach` statement?
std::async(func1);
func2();
std::async(func3);
func4();
With the `parallelForEach`, it sounds like we'll need to nest things because `parallelForEach` isn't meant to model concurrency but more about parallelism.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D115416/new/
https://reviews.llvm.org/D115416
More information about the llvm-commits
mailing list