[PATCH] D113968: [fir] Add fircg.ext_array_coor conversion
Kiran Chandramohan via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Dec 6 05:04:55 PST 2021
kiranchandramohan added inline comments.
================
Comment at: flang/lib/Optimizer/CodeGen/CodeGen.cpp:1817-1819
+ mlir::Value index = integerCast(loc, rewriter, idxTy, *indexOps);
+ mlir::Value lb =
+ isShifted ? integerCast(loc, rewriter, idxTy, *shiftOps) : one;
----------------
clementval wrote:
> kiranchandramohan wrote:
> > I think the indexOps and shiftOps are the original operands. We have to use the converted operands here I think.
> I don't think it would make a difference here in the end and probably harder to read to code with `operands` and indexing. WDYT?
If this is causing no issues now then it is OK with me. It might cause an issue in the future. Can you either add a TODO or create a ticket to clean it up in the future?
For the XReboxOp I had to use the converted operands to make it work.
https://reviews.llvm.org/D114709
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D113968/new/
https://reviews.llvm.org/D113968
More information about the llvm-commits
mailing list