[PATCH] D113968: [fir] Add fircg.ext_array_coor conversion

Valentin Clement via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Dec 6 05:00:51 PST 2021


clementval marked 3 inline comments as done.
clementval added inline comments.


================
Comment at: flang/lib/Optimizer/CodeGen/CodeGen.cpp:1817-1819
+      mlir::Value index = integerCast(loc, rewriter, idxTy, *indexOps);
+      mlir::Value lb =
+          isShifted ? integerCast(loc, rewriter, idxTy, *shiftOps) : one;
----------------
kiranchandramohan wrote:
> I think the indexOps and shiftOps are the original operands. We have to use the converted operands here I think.
I don't think it would make a difference here in the end and probably harder to read to code with `operands` and indexing. WDYT?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D113968/new/

https://reviews.llvm.org/D113968



More information about the llvm-commits mailing list