[PATCH] D114997: AMDGPU: Sanitized functions require implicit arguments
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Dec 2 15:15:35 PST 2021
arsenm added inline comments.
================
Comment at: llvm/lib/Target/AMDGPU/AMDGPUAttributor.cpp:117
+/// regardless of the function contents.
+static bool funcRequiresImplicitArgPtr(const Function &F) {
+ // Sanitizers require the hostcall buffer passed in the implicit arguments.
----------------
arsenm wrote:
> JonChesterfield wrote:
> > Whats the 'implicitArgPtr'? The comment suggests this refers to the hostcall/printf buffer thing at offset 24 but the function name does not. 'IMPLICIT_ARG_PTR' suggests this is an existing naming convention.
> >
> > The backend docs refer to 'Implicit Argument Ptr' in one place but don't state what it is. Nearby in the doc is 'Any source language implicit this or self argument comes first as a pointer type.' which I'm guessing is a conflict of notation. Could we call whatever this thing is something other than 'implicit arg/argument ptr'?
> It's the pointer to the implicit argument area in the kernarg segment. It's the base address, where at offset 24 is the hostcall buffer. I don't know what else it would be called. It's passed with the explicit kernel arguments in the same buffer
Plus it's already the name of the intrinsic
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D114997/new/
https://reviews.llvm.org/D114997
More information about the llvm-commits
mailing list