[PATCH] D114759: [NFC][regalloc] Factor accesses to ExtraRegInfo
Mircea Trofin via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Nov 30 13:49:37 PST 2021
mtrofin added inline comments.
================
Comment at: llvm/lib/CodeGen/RegAllocGreedy.cpp:224
+ void addNew(Register Reg) {
+ ExtraRegInfo.grow(Reg);
----------------
qcolombet wrote:
> Could you add a comment on what this method does?
split the functionality, which gave (I think) a more useful abstraction, that's also easier to describe.
================
Comment at: llvm/lib/CodeGen/RegAllocGreedy.cpp:236
+
+ void onNewRegCount(size_t Count) { ExtraRegInfo.resize(Count); }
+
----------------
qcolombet wrote:
> Ditto: comment on what it does?
>
> Put differently, the method names are not super informative.
Done. We don't actually need this, as we can handle it with setStage and the newly-introduced getOrInitStage
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D114759/new/
https://reviews.llvm.org/D114759
More information about the llvm-commits
mailing list