[PATCH] D114371: [Flang] Replace notifyMatchFailure with TODO hard failures

Kiran Chandramohan via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Nov 30 04:42:15 PST 2021


kiranchandramohan updated this revision to Diff 390664.
kiranchandramohan marked 5 inline comments as done.
kiranchandramohan added a comment.

Rename `not_cmd` as `not_todo_cmd`. Add comments.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D114371/new/

https://reviews.llvm.org/D114371

Files:
  flang/lib/Optimizer/CodeGen/CodeGen.cpp
  flang/test/CMakeLists.txt
  flang/test/Fir/Todo/boxproc_host.fir
  flang/test/Fir/Todo/dispatch.fir
  flang/test/Fir/Todo/dispatch_table.fir
  flang/test/Fir/Todo/emboxproc.fir
  flang/test/Fir/Todo/end.fir
  flang/test/Fir/Todo/gentypedesc.fir
  flang/test/Fir/Todo/global_len.fir
  flang/test/Fir/Todo/len_param_index.fir
  flang/test/Fir/Todo/select_case_with_character.fir
  flang/test/Fir/Todo/unboxproc.fir
  flang/test/Fir/convert-to-llvm-invalid.fir
  flang/test/lit.cfg.py

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D114371.390664.patch
Type: text/x-patch
Size: 19201 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20211130/8176ebb7/attachment.bin>


More information about the llvm-commits mailing list