[PATCH] D114542: [CodeGen][SVE] Use whilelo instruction when lowering @llvm.get.active.lane.mask
Paul Walker via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Nov 25 10:46:54 PST 2021
paulwalker-arm added inline comments.
================
Comment at: llvm/lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp:7112
+
+ if (!TLI.lowerGetActiveLaneMask(CCVT, ElementVT)) {
+ visitTargetIntrinsic(I, Intrinsic);
----------------
Probably bike shedding but I feel if there was an ISD node for this intrinsic then the code this function prevents would likely sit in a function called `expandGetActiveLaneMask` so perhaps a better name is `shouldExpandGetActiveLaneMask`?
I also think that given such a name the documentation can be very lightweight given expansion is a well established concept within the code generator.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D114542/new/
https://reviews.llvm.org/D114542
More information about the llvm-commits
mailing list