[PATCH] D113582: [lld-macho] Support renaming of LSDA section

Vy Nguyen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Nov 10 10:40:04 PST 2021


oontvoo added inline comments.


================
Comment at: lld/MachO/UnwindInfoSection.cpp:132
+  // in symbolsVec.
+  std::vector<CompactUnwindEntry<Ptr>> cuVector;
+  // Indices into the compact unwind vector.
----------------
for consistency, can we stick to one naming convention? :) (hungarian notation or not?)
does `cuEntries`work?


================
Comment at: lld/MachO/UnwindInfoSection.cpp:134
+  // Indices into the compact unwind vector.
+  std::vector<size_t> cuIdxVector;
   // Indices of personality functions within the GOT.
----------------
comment on what the significance of the entries pointed to by these indices is?


P.S: from reading further, it's an indirection from the page's index -> the cuVector's index .... would be good to have clarification


================
Comment at: lld/MachO/UnwindInfoSection.cpp:552
+                      entriesWithLsda.size() *
+                          sizeof(unwind_info_section_header_lsda_index_entry);
   unwindInfoSize =
----------------
shouldn't this be "size_t"? (because entriesWithLsda is storing the indices not the entries themselves?)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D113582/new/

https://reviews.llvm.org/D113582



More information about the llvm-commits mailing list