[PATCH] D112977: [lld-macho] Fix failed assertion in registerCompactUnwind

Vincent Lee via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Nov 3 22:31:27 PDT 2021


thevinster added inline comments.


================
Comment at: lld/test/MachO/dup-symbols-weak-def.s:16
+
+.globl  _uprv_getICUData_core
+
----------------
nit: I imagine this might be a name mangled from your internal systems. I think it would cleaner if we just renamed these to our usual names in all of our tests - `foo`, `bar`, `baz`, etc. 


================
Comment at: lld/test/MachO/dup-symbols-weak-def.s:20
+  .cfi_startproc
+        pushq   %rbp
+        .cfi_def_cfa_offset 16
----------------
nit: Here to `.cfi_endproc`, could we align this with `.cfi_startproc`? Same for the below function as well. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D112977/new/

https://reviews.llvm.org/D112977



More information about the llvm-commits mailing list