[PATCH] D112732: [ASan] Removed AddressSanitizerPass function pass class and rolled it into the module pass for the new pass mangager only.
Vitaly Buka via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 1 11:38:58 PDT 2021
vitalybuka added inline comments.
================
Comment at: llvm/include/llvm/Transforms/Instrumentation/AddressSanitizer.h:92
-struct AddressSanitizerOptions {
- AddressSanitizerOptions()
----------------
Why do we need to remove AddressSanitizerOptions?
================
Comment at: llvm/lib/Passes/PassRegistry.def:139
"kernel;recover")
MODULE_PASS_WITH_PARAMS("asan-module",
"ModuleAddressSanitizerPass",
----------------
And I guess now we need to use parseASanPassOptions here?
================
Comment at: llvm/lib/Passes/PassRegistry.def:396
"no-upperbound;upperbound")
-FUNCTION_PASS_WITH_PARAMS("asan",
- "AddressSanitizerPass",
----------------
vitalybuka wrote:
> you should also rename MODULE_PASS_WITH_PARAMS("asan-module", to just MODULE_PASS_WITH_PARAMS("asan",
I still see asan-module here
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D112732/new/
https://reviews.llvm.org/D112732
More information about the llvm-commits
mailing list