[PATCH] D112667: [lld][WebAssembly] Initialize bss segments using memory.fill

Sam Clegg via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Oct 28 11:54:18 PDT 2021


sbc100 added inline comments.


================
Comment at: lld/wasm/Writer.cpp:539
+
+void Writer::checkTargetFeatures() {
+  if (config->relocatable || !config->checkFeatures)
----------------
sbc100 wrote:
> tlively wrote:
> > There are still a bunch of other feature checks in the previous function. Would it make sense to break them out as well?
> Yes, I was thinking the same... or maybe try to give this function a better name?   or move these checks into calculateImports/calculateExports?
I renamed this function and added a comment.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D112667/new/

https://reviews.llvm.org/D112667



More information about the llvm-commits mailing list