[PATCH] D112513: [ELF] Replace InputBaseSection::{areRelocsRela,firstRelocation,numRelocation} with relSecIdx

Peter Smith via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 26 12:19:10 PDT 2021


peter.smith added a comment.

Only a small suggestion, no objections from me.



================
Comment at: lld/ELF/InputSection.h:38
+template <class ELFT> struct RelsOrRelas {
+  ArrayRef<typename ELFT::Rel> rels;
+  ArrayRef<typename ELFT::Rela> relas;
----------------
May be worth a member function like `bool areRelocsRel() const { return rels.size(); }` that could be used instead of `if (rels.rels.size())` not a strong opinion, may not be worth the change.    


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D112513/new/

https://reviews.llvm.org/D112513



More information about the llvm-commits mailing list