[PATCH] D112077: [NFC][LoopIdiom] Make for loops more readable
Dawid Jurczak via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Oct 19 07:57:11 PDT 2021
yurai007 added inline comments.
================
Comment at: llvm/lib/Transforms/Scalar/LoopIdiomRecognize.cpp:667
SmallVector<unsigned, 16> IndexQueue;
- for (unsigned i = 0, e = SL.size(); i < e; ++i) {
+ for (auto i = 0LU, e = SL.size(); i < e; ++i) {
assert(SL[i]->isSimple() && "Expected only non-volatile stores.");
----------------
That could be simplified a bit with 'seq' but extra headers need to included, so decided leave it as it is.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D112077/new/
https://reviews.llvm.org/D112077
More information about the llvm-commits
mailing list