[PATCH] D111703: [ARM] __cxa_end_cleanup should be called instead of _UnwindResume.
Logan Chien via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Oct 13 15:00:42 PDT 2021
logan added inline comments.
================
Comment at: libcxxabi/src/cxa_exception.cpp:345
+first argument to _Unwind_Resume(). In addition, we are saving lr in order to
+align the stack to 16 bytes and lr will be used to identify the caller and its frame information
+_Unwind_Resume never return and we need to keep the original lr so just branch to it.
----------------
BTW, please add a period to end the sentence after "... its frame information".
Also, please re-flow the text to fit in 80 columns.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D111703/new/
https://reviews.llvm.org/D111703
More information about the llvm-commits
mailing list