[PATCH] D110820: [fir][NFC] Move fir.select_type builder to cpp file

Valentin Clement via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Sep 30 13:12:03 PDT 2021


clementval added inline comments.


================
Comment at: flang/lib/Optimizer/Dialect/FIROps.cpp:2556
+  const auto count = destinations.size();
+  for (auto d : destinations)
+    result.addSuccessors(d);
----------------
mehdi_amini wrote:
> Can you fix the clang-tidy warning?
> 
> Also `auto` likely does not help readability compared to `mlir::Block *d`
> 
> (also: `dest` instead `d`?)
Sure. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D110820/new/

https://reviews.llvm.org/D110820



More information about the llvm-commits mailing list