[PATCH] D110820: [fir][NFC] Move fir.select_type builder to cpp file
Mehdi AMINI via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Sep 30 10:49:46 PDT 2021
mehdi_amini added inline comments.
================
Comment at: flang/lib/Optimizer/Dialect/FIROps.cpp:2556
+ const auto count = destinations.size();
+ for (auto d : destinations)
+ result.addSuccessors(d);
----------------
Can you fix the clang-tidy warning?
Also `auto` likely does not help readability compared to `mlir::Block *d`
(also: `dest` instead `d`?)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D110820/new/
https://reviews.llvm.org/D110820
More information about the llvm-commits
mailing list