[PATCH] D110080: [llvm-profgen] Unify output format of unsymbolized profiles

Wenlei He via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Sep 21 08:15:01 PDT 2021


wenlei added inline comments.


================
Comment at: llvm/tools/llvm-profgen/PerfReader.cpp:22
+cl::opt<bool> ShowRelativeAddress(
+    "show-relative-address", cl::ReallyHidden, cl::init(true), cl::ZeroOrMore,
+    cl::desc("Work with `--skip-symbolization` to dump the relative address to "
----------------
nit: `show-xx` is often used to output xx as extra. how about something like `[show-]address-as-offset` or `use-offset`. I'd change the term/variable name from relative address to offset too. 


================
Comment at: llvm/tools/llvm-profgen/PerfReader.cpp:595
+                         : Binary->offsetToVirtualAddr(I.first.second);
+      OS << Twine::utohexstr(Start) << "-" << Twine::utohexstr(End) << ":"
+         << I.second << "\n";
----------------
For CS raw profile (`!CI.first.empty()`), can we still keep the indentation like before for readability? Same for branch below. Otherwise it looks good.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D110080/new/

https://reviews.llvm.org/D110080



More information about the llvm-commits mailing list