[PATCH] D109888: Bitcast wrapped in a call obscures function attributes, pessimizing MemorySSA
Johannes Doerfert via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Sep 16 08:19:09 PDT 2021
jdoerfert added inline comments.
================
Comment at: llvm/lib/IR/Instructions.cpp:356-357
+ Value *V = getCalledOperand();
+ if (isa<ConstantExpr>(V) && cast<ConstantExpr>(V)->getOpcode() == BitCast)
+ V = cast<User>(V)->getOperand(0);
+
----------------
Style suggestion, OK to ignore. I find it easier to read (less casts).
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D109888/new/
https://reviews.llvm.org/D109888
More information about the llvm-commits
mailing list