[PATCH] D109666: [AArch64][SVE][InstCombine] Fold redundant zip(unzip) operations
Paul Walker via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Sep 15 08:40:44 PDT 2021
paulwalker-arm added inline comments.
================
Comment at: llvm/lib/Target/AArch64/AArch64TargetTransformInfo.cpp:799
+ // zip2(uzp1(A, B), uzp2(A, B)) --> B
+ Value *Uzp1Op0, *Uzp1Op1;
+ if (match(II.getArgOperand(0), m_Intrinsic<Intrinsic::aarch64_sve_uzp1>(
----------------
I think the function will be more readable if the names in the code matched the comment, i.e. can these just be `A` and `B`? Don't let this hold up the patch, if you agree it's just something to consider before pushing the change.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D109666/new/
https://reviews.llvm.org/D109666
More information about the llvm-commits
mailing list