[PATCH] D109448: [IRSim][IROutliner] Treating Called Functions as Values and Outlining Indirect Calls
Jon Roelofs via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Sep 14 08:53:45 PDT 2021
jroelofs added inline comments.
================
Comment at: llvm/include/llvm/Analysis/IRSimilarityIdentifier.h:139
+ /// another.
+ Optional<std::string> CallInstName;
+
----------------
I think `CalleeName` would be a better name for this.
================
Comment at: llvm/include/llvm/Analysis/IRSimilarityIdentifier.h:211
+ /// function name as a differentiating parameter.
+ void setFunctionName(bool MatchByName = true);
+
----------------
Likewise, this should probably be: `setCalleeName`
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D109448/new/
https://reviews.llvm.org/D109448
More information about the llvm-commits
mailing list