[PATCH] D109651: [Win64EH] Write .pdata symbol relocations relative to the temporary begin symbol

Martin Storsjö via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 13 12:18:37 PDT 2021


mstorsjo added inline comments.


================
Comment at: llvm/test/MC/COFF/seh.s:155
+// of the next, when llvm-readobj describes addresses with symbols
+    nop
 // Test emission of small functions.
----------------
mstorsjo wrote:
> efriedma wrote:
> > This is just to make the CHECK lines easier to read, I assume?
> Yes; currently they check that the StartAddress and EndAddress point at the same symbol, but without the nop, the EndAddress of `func` would be resolved by llvm-readobj into `smallFunc` instead of `func + offset` - otherwise I'd need to change those CHECK lines.
> 
> I guess the alternative would be to add even more logic into the resolving logic in llvm-readobj, see D109649, to not resolve `symbol + nonzero offset` into a symbol with a zero offset, for the EndAddress case.
I amended D109649, with that update I can drop this extra nop.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D109651/new/

https://reviews.llvm.org/D109651



More information about the llvm-commits mailing list