[PATCH] D108780: [lld-macho] Refactor archive loading
Vincent Lee via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Aug 28 16:32:28 PDT 2021
thevinster added inline comments.
================
Comment at: lld/MachO/InputFiles.cpp:1303
+ if (Error e = fetch(c, symCopy.getName()))
+ error(toString(this) + ": could not get the member defining symbol " +
+ toMachOString(symCopy) + ": " + toString(std::move(e)));
----------------
nit: I'm not sure what the standard practice is, but for readability, I feel like it would be more helpful to have this error message be different than L1292. This makes it easier to debug since `toMachOString` can contain hidden a `:`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108780/new/
https://reviews.llvm.org/D108780
More information about the llvm-commits
mailing list