[PATCH] D108187: [RISCV] Rename FeatureStdExtZvlsseg to FeatureExtZvlsseg

Hsiangkai Wang via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Aug 24 04:46:59 PDT 2021


HsiangKai added inline comments.


================
Comment at: llvm/lib/Target/RISCV/RISCV.td:177
+def FeatureExtZvlsseg
     : SubtargetFeature<"experimental-zvlsseg", "HasStdExtZvlsseg", "true",
                        "'Zvlsseg' (Vector segment load/store instructions)",
----------------
Jim wrote:
> craig.topper wrote:
> > This patch makes things consistent, but I'm not sure why the bools in RISCVSubtarget.h have "Std" in their name.
> The bools have prefix hasStdExt*. All of sub-extensions are all the same. 
> Or the SubtargetFeatures should be fixed to have prefix FeatureStdExt* for all of sub-extension.
I prefer to make it consistent for subtarget features. To add all "Std", include sub-extensions.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D108187/new/

https://reviews.llvm.org/D108187



More information about the llvm-commits mailing list