[PATCH] D106643: [llvm-readobj][XCOFF] Add support for `--needed-libs` option.

James Henderson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 18 00:26:22 PDT 2021


jhenderson added a comment.

I think you need testing for long names in your test case, to show the column width adjustments.



================
Comment at: llvm/tools/llvm-readobj/XCOFFDumper.cpp:484
 
+static void getMaxNameWitdth(const char *CurrentStr, const char *TableEnd,
+                             size_t &BaseWidth, size_t &MemberWidth) {
----------------
The name here is somewhat generic, but the functionality is tied to the needed libraries implementation (i.e. it's to do with the base/member columns specifically). It probably makes more sense to just inline this function, since it's only caleld once.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D106643/new/

https://reviews.llvm.org/D106643



More information about the llvm-commits mailing list