[PATCH] D107996: [libunwind] Rename UNW_ARM64_* to UNW_AARCH64_*

Saleem Abdulrasool via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Aug 17 16:09:18 PDT 2021


compnerd added a subscriber: Bigcheese.
compnerd added inline comments.


================
Comment at: libunwind/include/libunwind.h:567
-  UNW_ARM64_D31 = 95,
+  UNW_AARCH64_D0 = 64,
+  UNW_AARCH64_D1 = 65,
+  UNW_AARCH64_D2 = 66,
+  UNW_AARCH64_D3 = 67,
+  UNW_AARCH64_D4 = 68,
+  UNW_AARCH64_D5 = 69,
+  UNW_AARCH64_D6 = 70,
+  UNW_AARCH64_D7 = 71,
+  UNW_AARCH64_D8 = 72,
+  UNW_AARCH64_D9 = 73,
+  UNW_AARCH64_D10 = 74,
+  UNW_AARCH64_D11 = 75,
+  UNW_AARCH64_D12 = 76,
+  UNW_AARCH64_D13 = 77,
+  UNW_AARCH64_D14 = 78,
+  UNW_AARCH64_D15 = 79,
+  UNW_AARCH64_D16 = 80,
+  UNW_AARCH64_D17 = 81,
+  UNW_AARCH64_D18 = 82,
+  UNW_AARCH64_D19 = 83,
+  UNW_AARCH64_D20 = 84,
+  UNW_AARCH64_D21 = 85,
+  UNW_AARCH64_D22 = 86,
+  UNW_AARCH64_D23 = 87,
+  UNW_AARCH64_D24 = 88,
+  UNW_AARCH64_D25 = 89,
+  UNW_AARCH64_D26 = 90,
+  UNW_AARCH64_D27 = 91,
+  UNW_AARCH64_D28 = 92,
+  UNW_AARCH64_D29 = 93,
+  UNW_AARCH64_D30 = 94,
+  UNW_AARCH64_D31 = 95,
 };
 
----------------
This is a public header, I don't think that changing this like this without compatibility is good.  I _could_ be convinced that this isn't too big of a deal if @Bigcheese signs off on this on behalf of Apple.

However, I wouldn't mind if we had aliases for the name.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D107996/new/

https://reviews.llvm.org/D107996



More information about the llvm-commits mailing list