[PATCH] D107070: [Dexter] Improve Dexter's performance by evaluating expressions only when needed
Chris Jackson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Aug 6 04:34:17 PDT 2021
chrisjackson added a comment.
A couple of nits, really nice patch though! Its really going to improve things.
================
Comment at: cross-project-tests/debuginfo-tests/dexter/dex/command/commands/DexExpectProgramState.py:59
def get_watches(self):
- frame_expects = chain.from_iterable(frame.watches
- for frame in self.expected_program_state.frames)
+ frame_expects = chain.from_iterable((
+ StepExpectInfo(
----------------
I'm keen on ternary ifs myself, but coupled with the construction of a StepExpectInfo in a from_iterable I feel this block could be a little hard to read. But I concede its just personal preference.
================
Comment at: cross-project-tests/debuginfo-tests/dexter/dex/debugger/DebuggerBase.py:23
+ _, watch_path, watch_frame_idx, watch_line_range = watch_info
+ if (watch_path and os.path.isfile(watch_path) and
+ (not path or not os.path.isfile(path) or
----------------
Possibly awkward to read combination of and, not, or. Is there a nicer way to expess this? Just a nit really.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D107070/new/
https://reviews.llvm.org/D107070
More information about the llvm-commits
mailing list