[PATCH] D106605: Add `all_of_zip` to STLExtras
River Riddle via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jul 23 10:30:36 PDT 2021
rriddle added inline comments.
================
Comment at: llvm/include/llvm/ADT/STLExtras.h:1704
+template <typename R, typename U, typename Predicate>
+Optional<bool> all_of_zip(R &&Lhs, U &&Rhs, Predicate P) {
+ auto Literator = adl_begin(Lhs);
----------------
The name here feels a bit weird. This is essentially just std::ranges::equal/std::equal with special size mismatch behavior. Can we name it something closer to what it would be replaced by? Also, in what situations is the size mismatch result needed (i.e. the llvm::None)?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D106605/new/
https://reviews.llvm.org/D106605
More information about the llvm-commits
mailing list