[PATCH] D105168: [RISCV] Unify the arch string parsing logic to RISCVISAInfo.
Kito Cheng via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jul 23 02:43:23 PDT 2021
kito-cheng marked an inline comment as done.
kito-cheng added inline comments.
================
Comment at: llvm/include/llvm/Support/RISCVISAInfo.h:45
+
+ // Parse RISCV ISA info from arch string.
+ Error parse(StringRef Arch, bool EnableExperimentalExtension,
----------------
jrtc27 wrote:
> These comments aren't helpful. If you want to write full doxygen then you can, but a one-line comment that won't appear in documentation and is obvious from the function name and signature is just clutter.
Rename RISCVISAInfo::parse to RISCVISAInfo::parseFeatures/RISCVISAInfo::parseArchString, I guess it should be more clear.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D105168/new/
https://reviews.llvm.org/D105168
More information about the llvm-commits
mailing list