[PATCH] D106272: [AArch64][SME] Introduce feature for streaming mode

Cullen Rhodes via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 22 02:21:35 PDT 2021


c-rhodes added inline comments.


================
Comment at: llvm/lib/Target/AArch64/AArch64SVEInstrInfo.td:618
 
-  defm COMPACT_ZPZ : sve_int_perm_compact<"compact", int_aarch64_sve_compact>;
   defm INSR_ZR : sve_int_perm_insrs<"insr", AArch64insr>;
----------------
sdesmalen wrote:
> Instead of moving these around, can you do:
>   let Predicates = [HasSVEOrStreamingSVE] in {
>     ...
>     defm SPLICE_ZPZ : sve_int_perm_splice<"splice", AArch64splice>;
>   }
>   
>   let Predicates = [HasSVE] in {
>     defm COMPACT_ZPZ : sve_int_perm_compact<"compact", int_aarch64_sve_compact>;
>   }
>   
>   let Predicates = [HasSVEOrStreamingSVE] in {
>     defm INSR_ZR : sve_int_perm_insrs<"insr", AArch64insr>;
>     defm INSR_ZV : sve_int_perm_insrv<"insr", AArch64insr>;
>     defm EXT_ZZI : sve_int_perm_extract_i<"ext", AArch64ext>;
>     ...
>   }
> 
> That makes the patch easier to review, and we could possibly follow this up with a separate NFC change that shuffles these around in the file for readability (although I'm not sure yet if that's necessarily what we want).
> Instead of moving these around, can you do:
>   let Predicates = [HasSVEOrStreamingSVE] in {
>     ...
>     defm SPLICE_ZPZ : sve_int_perm_splice<"splice", AArch64splice>;
>   }
>   
>   let Predicates = [HasSVE] in {
>     defm COMPACT_ZPZ : sve_int_perm_compact<"compact", int_aarch64_sve_compact>;
>   }
>   
>   let Predicates = [HasSVEOrStreamingSVE] in {
>     defm INSR_ZR : sve_int_perm_insrs<"insr", AArch64insr>;
>     defm INSR_ZV : sve_int_perm_insrv<"insr", AArch64insr>;
>     defm EXT_ZZI : sve_int_perm_extract_i<"ext", AArch64ext>;
>     ...
>   }
> 
> That makes the patch easier to review, and we could possibly follow this up with a separate NFC change that shuffles these around in the file for readability (although I'm not sure yet if that's necessarily what we want).

that's a better idea, done :) 


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D106272/new/

https://reviews.llvm.org/D106272



More information about the llvm-commits mailing list