[PATCH] D105429: [JITLink][RISCV] Initial Support RISCV64 in JITLink

Lang Hames via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 21 01:41:43 PDT 2021


lhames added a comment.

@StephenFan -- Thanks for splitting those edge kinds out!

Now that you've moved the edge kinds into their own header the `getELFRISCVRelocationKindName` function should be renamed/declared as `getEdgeKindName` in the riscv namespace in riscv.h, and the implementation moved to a new riscv.cpp file (to mirror x86_64::getEdgeKindName). This is a minor request though: I don't mind whether it happens as part of this review, before you commit, or in-tree after it lands. From my point of view this is new functionality, and it'd be a win to land it in-tree sooner rather than later so that other people can start checking it out.

@jrtc27 -- did you have any further fixes that you want before this lands?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D105429/new/

https://reviews.llvm.org/D105429



More information about the llvm-commits mailing list