[PATCH] D105867: [WIP][lld-macho] Optimize bind opcodes with multiple passes

Vincent Lee via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 14 15:47:20 PDT 2021


thevinster added a comment.

In D105867#2873885 <https://reviews.llvm.org/D105867#2873885>, @tschuett wrote:

> There is twice a `15` in your code. Are these magic numbers or could they be named constants?

`15` is the limit for data to be compacted within a single byte; otherwise it needs to be expanded. It turns out there is already a constant BIND_IMMEDIATE_MASK that already defines these values. I plan to separate pass 3 in a separate diff since that might involve some more changes.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D105867/new/

https://reviews.llvm.org/D105867



More information about the llvm-commits mailing list