[PATCH] D104218: [ADT] Add StringRef consume_front_lower and consume_back_lower

Chris Lattner via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jun 21 21:53:56 PDT 2021


lattner accepted this revision.
lattner added a comment.
This revision is now accepted and ready to land.

Aha, I see this is consistent with the existing naming convention for this, so I'm ok with it.

That said, `xxx_lower()` is a really terrible name here for insensitive comparisons.  We have `StringRef::lower()` which returns a lower case string - it isn't insensitive.  It seems that the whole family needs a rename.  Could you take a crack at this as a follow-up?  It should be a mechanical change.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D104218/new/

https://reviews.llvm.org/D104218



More information about the llvm-commits mailing list