[PATCH] D104668: [OpaquePtr] Handle addrspacecasts in InstCombine
Nikita Popov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jun 21 14:40:22 PDT 2021
nikic added a comment.
> Any thoughts on the approach here? Is the `!isOpaque() ? getElementType() : nullptr ` pattern something we should add a helper function for? Not sure how common this is going to be outside these cast transforms.
Or possibly `PointerType::hasSameElementTypeAs(PointerType *)` would make sense here.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D104668/new/
https://reviews.llvm.org/D104668
More information about the llvm-commits
mailing list