[PATCH] D100132: [libunwind][AIX] implementation of the unwinder for AIX
Xing Xue via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jun 15 07:54:12 PDT 2021
xingxue updated this revision to Diff 352128.
xingxue retitled this revision from "[libunwind][AIX] Initial patch of the unwinder on AIX" to "[libunwind][AIX] implementation of the unwinder for AIX".
xingxue edited the summary of this revision.
xingxue edited reviewers, added: compnerd; removed: ldionne.
xingxue added a comment.
Addressed comments.
File `UnwindCursor.hpp`:
- Pulled the checking and skipping `name_len` and `name` fields out of the body of the `if` statement that checks `uses_alloca` field for better readability.
- Added asserts if dlopen() or dlsym() fail.
- Changed text in assert messages from `XLC++` to `libunwind`.
File `Unwind_AIXExtras.cpp`:
- In function `getFuncName()` switched order to return early.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D100132/new/
https://reviews.llvm.org/D100132
Files:
libunwind/include/__libunwind_config.h
libunwind/include/libunwind.h
libunwind/src/AddressSpace.hpp
libunwind/src/CMakeLists.txt
libunwind/src/Registers.hpp
libunwind/src/UnwindCursor.hpp
libunwind/src/UnwindLevel1-gcc-ext.c
libunwind/src/UnwindLevel1.c
libunwind/src/UnwindRegistersRestore.S
libunwind/src/UnwindRegistersSave.S
libunwind/src/Unwind_AIXExtras.cpp
libunwind/src/assembly.h
libunwind/src/config.h
libunwind/src/libunwind.cpp
libunwind/src/libunwind_ext.h
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D100132.352128.patch
Type: text/x-patch
Size: 42710 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20210615/7ff16f18/attachment.bin>
More information about the llvm-commits
mailing list