[PATCH] D103912: LoadStoreVectorizer: support different operand orders in the add sequence match
Viacheslav Nikolaev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jun 10 14:48:51 PDT 2021
wvoquine marked 6 inline comments as done.
wvoquine added inline comments.
================
Comment at: llvm/lib/Transforms/Vectorize/LoadStoreVectorizer.cpp:393
+static bool checkIfSafeAddSequence(const APInt &IdxDiff, Instruction *AddOpA,
+ unsigned MatchinOperandA,
+ Instruction *AddOpB,
----------------
volkan wrote:
> You can rename `MatchinOperand[AB]` as `MatchinOpIdx[AB]` or `MatchinOperandIdx[AB]` to make it clear that this is an index.
I like MatchingOpIdx[AB] - by the way, I missed `g` in `Matching` too, thanks!
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D103912/new/
https://reviews.llvm.org/D103912
More information about the llvm-commits
mailing list