[PATCH] D100464: [DSE] Remove stores in the same loop iteration

Dave Green via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 25 14:46:40 PDT 2021


dmgreen updated this revision to Diff 347783.
dmgreen added a comment.

Changed IsGuaranteedLoopInvariant to isGuaranteedLoopInvariant (if this wasn't what you meant, let me know, and do you have suggestions for a better name?)
Reworded comments.
Fixed Later->Earlier memref, which then needed a rejig of one of the test to move the initial memloc out of the entry block.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D100464/new/

https://reviews.llvm.org/D100464

Files:
  llvm/lib/Transforms/Scalar/DeadStoreElimination.cpp
  llvm/test/CodeGen/AMDGPU/opt-pipeline.ll
  llvm/test/Other/opt-O2-pipeline.ll
  llvm/test/Other/opt-O3-pipeline-enable-matrix.ll
  llvm/test/Other/opt-O3-pipeline.ll
  llvm/test/Other/opt-Os-pipeline.ll
  llvm/test/Transforms/DeadStoreElimination/multiblock-loops.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D100464.347783.patch
Type: text/x-patch
Size: 14112 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20210525/0e9a81f5/attachment.bin>


More information about the llvm-commits mailing list