[PATCH] D102971: [lld-macho][nfc] Rename MergedOutputSection to ConcatOutputSection
Jez Ng via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat May 22 17:52:18 PDT 2021
int3 created this revision.
int3 added a reviewer: lld-macho.
Herald added a subscriber: mgorny.
Herald added a reviewer: gkm.
Herald added a project: lld-macho.
int3 requested review of this revision.
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.
The ELF format has the concept of merge sections (marked by SHF_MERGE),
which contain data that can be safely deduplicated. The Mach-O
equivalents are called literal sections (marked by S_CSTRING_LITERALS or
S_{4,8,16}BYTE_LITERALS). While the Mach-O format doesn't use the word
'merge', to avoid confusion, I've renamed our MergedOutputSection to
ConcatOutputSection. I believe it's a more descriptive name too.
This renaming sets the stage for D102964: [lld-macho] Implement cstring merging / deduplication <https://reviews.llvm.org/D102964>.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D102971
Files:
lld/MachO/CMakeLists.txt
lld/MachO/ConcatOutputSection.cpp
lld/MachO/ConcatOutputSection.h
lld/MachO/MergedOutputSection.cpp
lld/MachO/MergedOutputSection.h
lld/MachO/OutputSegment.cpp
lld/MachO/Symbols.cpp
lld/MachO/SyntheticSections.cpp
lld/MachO/SyntheticSections.h
lld/MachO/UnwindInfoSection.cpp
lld/MachO/UnwindInfoSection.h
lld/MachO/Writer.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D102971.347218.patch
Type: text/x-patch
Size: 12202 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20210523/cdaf0f80/attachment.bin>
More information about the llvm-commits
mailing list