[PATCH] D100671: [ADT] Factor out in_place_t and expose in Optional ctor

David Blaikie via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 14 15:47:49 PDT 2021


dblaikie accepted this revision.
dblaikie added a comment.
This revision is now accepted and ready to land.

Looks good, thanks! Probably skip the other two in_place_* until we have a use for them.



================
Comment at: llvm/include/llvm/ADT/STLForwardCompat.h:53-73
+
+template <typename T>
+struct in_place_type_t // NOLINT(readability-identifier-naming)
+{
+  explicit in_place_type_t() = default;
+};
+/// \warning This must not be odr-used, as it cannot be made \c inline in C++14.
----------------
I'd probably skip these until we have a use for them?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D100671/new/

https://reviews.llvm.org/D100671



More information about the llvm-commits mailing list