[PATCH] D102262: [ValueTypes] Rename MVT::getVectorNumElements() to MVT::getVectorMinNumElements(). Fix some misuses of getVectorNumElements()
Craig Topper via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 12 07:40:16 PDT 2021
craig.topper added inline comments.
================
Comment at: llvm/lib/Target/X86/X86ISelLowering.cpp:2104
- if (VT.getVectorNumElements() != 1 &&
+ if (!VT.isScalableVector() && VT.getVectorNumElements() != 1 &&
VT.getVectorElementType() != MVT::i1)
----------------
frasercrmck wrote:
> You could probably also express this (and elsewhere) with `!VT.getVectorElementCount().isScalar()` as is done in some other places, but I'm undecided which is better
Wouldn't !VT.getVectorElementCount().isScalar() be equivalent to (isScalableVector || VT.getVectorNumElements() != 1). I don't think that's what we want here.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D102262/new/
https://reviews.llvm.org/D102262
More information about the llvm-commits
mailing list