[PATCH] D102262: [ValueTypes] Rename MVT::getVectorNumElements() to MVT::getVectorMinNumElements(). Fix some misuses of getVectorNumElements()
Craig Topper via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue May 11 16:38:01 PDT 2021
craig.topper updated this revision to Diff 344593.
craig.topper added a comment.
Herald added subscribers: kerbowa, kbarton, nhaehnle, jvesely, nemanjai, arsenm, jholewinski.
Fix a few more issues in some target's getPreferredAction.
Majority of remaining issues are in GlobalISel on AArch64
due to LLT not handling scalable vectors. Failing cases are
LLT is constructed from getMinimalRegClassLLT.
There are two additional failures
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D102262/new/
https://reviews.llvm.org/D102262
Files:
llvm/include/llvm/Support/MachineValueType.h
llvm/lib/Target/AMDGPU/SIISelLowering.cpp
llvm/lib/Target/Hexagon/HexagonISelLowering.cpp
llvm/lib/Target/NVPTX/NVPTXISelLowering.cpp
llvm/lib/Target/PowerPC/PPCISelLowering.h
llvm/lib/Target/X86/X86ISelLowering.cpp
llvm/utils/TableGen/CodeGenDAGPatterns.cpp
llvm/utils/TableGen/IntrinsicEmitter.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D102262.344593.patch
Type: text/x-patch
Size: 7577 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20210511/bbfee994/attachment.bin>
More information about the llvm-commits
mailing list