[PATCH] D102275: [x86] try to use PCMPGT instead of not-of-PCMPEQ
Roman Lebedev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue May 11 13:44:45 PDT 2021
lebedev.ri added a comment.
Seems reasonable to me.
================
Comment at: llvm/lib/Target/X86/X86ISelLowering.cpp:23082-23084
+ // X != INT_MIN --> X > INT_MIN
+ // X != INT_MAX --> X < INT_MAX --> INT_MAX > X
+ // +X != 0 --> X > 0
----------------
I think this could be a bit more readable if it specified the u/s of the comparison predicates.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D102275/new/
https://reviews.llvm.org/D102275
More information about the llvm-commits
mailing list