[PATCH] D101913: [CodeGen][WebAssembly] Better lowering for WASM_SYMBOL_TYPE_GLOBAL symbols
Andy Wingo via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 5 08:29:19 PDT 2021
wingo added a comment.
Hi! Please take a look. The code duplication is horrible and suggestions to fix are most welcome. Normally, overriding `emitGlobalVariable` would be sufficient, but we also need to visit uses of Wasm globals, even if they aren't defined in the compilation unit. The code in `GetGlobalAddressSymbol` would be sufficient, but we also need to visit definitions that aren't used. Irritating!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D101913/new/
https://reviews.llvm.org/D101913
More information about the llvm-commits
mailing list