[PATCH] D101838: [X86]Fix a crash trying to convert indices to proper type.

Simon Pilgrim via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 4 11:04:57 PDT 2021


RKSimon added inline comments.


================
Comment at: llvm/test/CodeGen/X86/vector-extract-bitcast.ll:2
+; NOTE: Assertions have been autogenerated by utils/update_llc_test_checks.py
+; RUN: llc < %s -mtriple=x86_64-unknown-unknown -mattr=+avx | FileCheck %s
+
----------------
It'd be better to add this test inside var-permute-128.ll I think.


================
Comment at: llvm/test/CodeGen/X86/vector-extract-bitcast.ll:4
+
+define void @_Z1fv() local_unnamed_addr {
+; CHECK-LABEL: _Z1fv:
----------------
Please can you drop the local_unnamed_addr and give function a better name


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D101838/new/

https://reviews.llvm.org/D101838



More information about the llvm-commits mailing list