[PATCH] D101196: [SCEV] Handle uge/ugt predicates in applyLoopGuards()
Nikita Popov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 27 13:40:06 PDT 2021
nikic marked an inline comment as done.
nikic added inline comments.
================
Comment at: llvm/test/Analysis/ScalarEvolution/max-backedge-taken-count-guard-info.ll:636
%shr = lshr i32 %blockSize, 2
%guard = icmp ult i32 %blockSize, 4
br i1 %guard, label %while.end, label %while.body.preheader
----------------
fhahn wrote:
> IMO it would slightly increase the readability of the test here if we would use the `uge` predicate, as in the test name :)
Yeah, that makes a lot more sense :) I just picked picked the order from the original test case...
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D101196/new/
https://reviews.llvm.org/D101196
More information about the llvm-commits
mailing list