[PATCH] D99750: [LV, VP] RFC: VP intrinsics support for the Loop Vectorizer (Proof-of-Concept)

Fraser Cormack via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Apr 16 02:31:08 PDT 2021


frasercrmck added a comment.

Overall, at a high-level, this LGTM too. I might play around with it locally if I find the time.



================
Comment at: llvm/include/llvm/Analysis/TargetTransformInfo.h:1381
+  /// TripCount - Induction).
+  bool useCustomActiveVectorLengthIntrinsic() const;
+
----------------
Part of me wants to say this should be `usesCustomActiveVectorLengthIntrinsic` like "the target `hasActiveVectorLength`" and "the target `supportsScalableVectors`".

I'm not arguing very strongly though because we have `preferPredicatedReductionSelect`. I know, it's the epitome of bikeshedding. I don't know if it's any better if it's self-aware.


================
Comment at: llvm/include/llvm/IR/Intrinsics.td:1346
+// Memory Intrinsics
+def int_vp_store : DefaultAttrsIntrinsic<[],
+                             [ llvm_anyvector_ty,
----------------
These need to go in the LangRef, don't they?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D99750/new/

https://reviews.llvm.org/D99750



More information about the llvm-commits mailing list