[PATCH] D98475: [LoopInterchange] Fix transformation bugs in loop interchange
Bardia Mahjour via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 6 13:43:51 PDT 2021
bmahjour added a comment.
Thanks for fixing this problem. I just have some comments about the tests, otherwise LGTM.
================
Comment at: llvm/test/Transforms/LoopInterchange/outer-header-jump-to-inner-latch.ll:5
+ at a = common global i32 0, align 4
+ at .str = private constant [4 x i8] c"%d\0A\00", align 1
+
----------------
[nit] unused, please remove it.
================
Comment at: llvm/test/Transforms/LoopInterchange/outer-header-jump-to-inner-latch.ll:8
+
+ at e = common dso_local local_unnamed_addr global i32 0, align 4
+ at d = common dso_local local_unnamed_addr global [1 x [6 x i32]] zeroinitializer, align 4
----------------
[nit] unused, please remove it.
================
Comment at: llvm/test/Transforms/LoopInterchange/outer-header-jump-to-inner-latch.ll:12
+; Doubly nested loop
+; Function Attrs: nofree nounwind
+define i32 @test1() {
----------------
Could you please put the C example here as a comment.
================
Comment at: llvm/test/Transforms/LoopInterchange/outer-header-jump-to-inner-latch.ll:90
+
+; Triply nested loop
+define internal fastcc void @test2() unnamed_addr #1 {
----------------
Please put the C example as a comment and mention which loops get interchanged for better readability.
================
Comment at: llvm/test/Transforms/LoopInterchange/outer-header-jump-to-inner-latch.ll:136
+
+for.cond4.preheader.lr.ph.i: ; preds = %for.end13.i, %entry
+ %g.addr.05.i = phi i32 [ 10, %entry ], [ %sub.i, %for.end13.i ]
----------------
could you please rename these labels to make them more meaningful?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D98475/new/
https://reviews.llvm.org/D98475
More information about the llvm-commits
mailing list