[PATCH] D99875: [Statepoint] Factor-out utility function to get non-foldable area of STATEPOINT like instructions. NFC

Serguei Katkov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 5 02:07:56 PDT 2021


skatkov added inline comments.


================
Comment at: llvm/include/llvm/CodeGen/TargetInstrInfo.h:1073
+  virtual std::pair<unsigned, unsigned>
+  getNonFoldableRange(const MachineInstr &MI) const;
+
----------------
to be honest, not happy with the name.
Actually I also want to use this function to determine what operands are ok to use both stack and register...
Any suggestions for the name?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D99875/new/

https://reviews.llvm.org/D99875



More information about the llvm-commits mailing list