[PATCH] D99449: [GlobalISel] Implement lowering for G_ROTR and G_ROTL.

Jay Foad via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Mar 30 01:11:22 PDT 2021


foad accepted this revision.
foad added a comment.
This revision is now accepted and ready to land.

Looks fine to me modulo the naming nit.



================
Comment at: llvm/include/llvm/CodeGen/GlobalISel/LegalizerHelper.h:351
   LegalizeResult lowerFunnelShift(MachineInstr &MI);
+  LegalizeResult lowerRotateWithOppositeRotate(MachineInstr &MI);
+  LegalizeResult lowerRotate(MachineInstr &MI);
----------------
Nit: "opposite" is now the third word we're using for the same thing. The code calls it "reverse", and the equivalent funnel shift function (three lines up) calls it "inverse". Could we standardize on one? I'd vote for "reverse".


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D99449/new/

https://reviews.llvm.org/D99449



More information about the llvm-commits mailing list