[PATCH] D99342: [flang] Fix CHECK() calls on erroneous procedure declarations
Pete Steinfeld via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Mar 25 10:41:29 PDT 2021
PeteSteinfeld added inline comments.
================
Comment at: flang/include/flang/Semantics/symbol.h:86
}
+ const Symbol *get_result() { return result_; }
void set_result(Symbol &result) {
----------------
PeteSteinfeld wrote:
> klausler wrote:
> > The f18 naming conventions would prefer something like GetResult.
> Thanks for catching this. I meant to create an accessor for `result_`. I'll rename it to `result()`.
Oops. There's already an accessor. I'll rename it `GetResult` as you suggest.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99342/new/
https://reviews.llvm.org/D99342
More information about the llvm-commits
mailing list