[PATCH] D98866: [KnownBits] Add knownbits analysis for mulhs/mulu 'multiply high' instructions

Jay Foad via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 18 10:23:51 PDT 2021


foad added inline comments.


================
Comment at: llvm/lib/Support/KnownBits.cpp:498
+  KnownBits WideRHS = RHS.sext(2 * BitWidth);
+  return computeForMul(WideLHS, WideRHS).extractBits(BitWidth, BitWidth);
+}
----------------
nikic wrote:
> Side note, we should rename computeForMul -> mul.
I would vote for `operator*`.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98866/new/

https://reviews.llvm.org/D98866



More information about the llvm-commits mailing list